Error loading webpart: The Rss Feed could not be acessed [sic]

Sep 14, 2009 at 11:26 AM

I get the following error in the Webcoda webpart when trying to display the feed

Error loading webpart: The Rss Feed: '' could not be acessed.

That feed displays in other RSS viewers, like the out of the box Sharepoint viewer.  Any idea why I'm getting that error with Webcoda?  By the way, there's a typo in that error message, it should read "accessed".


Sep 25, 2009 at 8:32 AM

Hi chdub,

Thanks a lot for posting your comments, we really appreciate all feedback!!

It looks like the Irish Times feed doesn't adhere to the RSS standard because it doesn't include the root <rss> node.  Instead, it seems be more of a RDF feed instead of a RSS feed.

According to the RSS Specification, this node must be present in order to be valid:  "At the top level, a RSS document is a <rss> element, with a mandatory attribute called version, that specifies the version of RSS that the document conforms to." Source:

As you can see in the following link, the Irish Times RSS feed doesn't seem to be valid:

Unfortunately, it wouldn't be a good idea on our part to change the code to support a non-standard RSS feed.  As this is an open-source project, you're more than welcome to modify the code yourself (we'd love to see the results if you do) or I guess it may be worth a shot trying to get Irish Times to standardize their feed.

Hope this helps.  Good luck!





Oct 20, 2009 at 1:12 PM

Hi Webcoda,

The issue is not with any rss standard or Irish Times feed. The issue is a well known issue discussed here:

Kindly help us fix this, as the only solution all suggest is to use kerberos for RSS, which is completely changing the whole site from NTLM to Kerberos, making not much sense.

Instead, it would be better to change all RSS viewer to work even in NTLM.

Nothing much here to change this code as it is basic issue with RSS viewers.

Yet to check on Codeplex RSS Aggregator!



Oct 21, 2009 at 10:38 AM
Edited Oct 21, 2009 at 1:57 PM


I found the way to display this and all RSS viewers. Instead of Kerberos, set the below proxy setting in web.config:



      <proxy usesystemdefault="false" proxyaddress="http://proxyservername:8080" bypassonlocal="true" />



Now RSS viewer, including Webcoda's working for me!

Really surprising one is, why any of the RSS Viewer sites, including microsoft advice this setting, which is more commonly happening in development environment for SharePoint developers.






Dec 10, 2009 at 8:21 AM


I too have a problem with my RSS feeds in the production environment at the client.

I modified the source code for an error message more clear and that is what I get: "Error loading webpart: The Rss Feed: '/_layouts/listfeed.aspx?List=%7B8C70BA23%2DAEBC%2D4856%2DA14E%2DD2A9E614B02E%7D' could not be acessed.
The remote server returned an error: (401) Unauthorized.
at System.Net.HttpWebRequest.GetResponse()
at Webcoda.SP.WP.RssRotator.GetResponse()"

I  put  the webpart settings  an internal link , but an external link gives me the same thing.

Have you any idea? This is quite urgent.

Thank you


Dec 10, 2009 at 9:02 AM

Re hello I bring a small detail:

The client has two redundant servers. With a virtual IP and a static IP.

In log file, we see that the skin files are searched by the IP client and the file Listfeed.asx is sought by the virtual IP.

Dec 15, 2009 at 12:25 AM


try this:

1) Check that users can access  http://[your site]/_layouts/listfeed.aspx?List=%7B8C70BA23%2DAEBC%2D4856%2DA14E%2DD2A9E614B02E%7D url.

2) Use IP address in RSS feed url so it is the same as for skin files: http://[IP client]/_layouts/listfeed.aspx?List=%7B8C70BA23%2DAEBC%2D4856%2DA14E%2DD2A9E614B02E%7D

Hope this helps.